NMI: Parity Check/Memory parity error

Asked By 220 points N/A Posted on -

Hello brothers,

Why is this happening all of a sudden. how can I fix this. I cannot afford to replace any spares not can I buy a new one.

Its a old P III desktop and was working fine till today morning.

I haven't added anything new nor.

Hardware malfunction.

Call your hardware vendor for support.

NMI: Parity Check/Memory parity error.

The system has halted.

Any help is of great use to me.

Best Answer by MayAnn
Best Answer
Best Answer
Answered By 0 points N/A #99820

NMI: Parity Check/Memory parity error



The error you are having is in no way a software issue but is no doubt a hardware issue. Now there are a couple of things that could be causing this error but this is limited to hardware that has memory in it like Video Card, Sound Card, RAM etc.

There are things you can check to see what is causing this issue and hopefully resolve it:

1. Try cleaning the inside of your system, remove any dust that might be lurking on your motherboard and expansion cards, make sure they are dust free. Dust can cause this unusual error as well.
2. Make sure your system is properly fanned and is not overheating, this error can also be caused by overheating components like the RAM memory or Video Card.
3. If all else fail, try to determine what could be causing this error, which hardware is it, you can try removing components that can removed and determine if the error still exist, once you determine the culprit, if you've made sure it is not overheating or just plain dusty, there’s a possibility that you have no choice but to replace the component.

Answered By 0 points N/A #99822

NMI: Parity Check/Memory parity error


This error occurs when there is a damaged hardware, unsuitable drivers’ installations and malfunction of hardware components.

Firstly check your RAM card and motherboard cache memory after that go for other components. If you have installed any new driver, uninstall them. (There can be drivers which are automatically update. Find them and disable that option)

Login/Register to Answer

Related Questions