My Windows Live Mail could not be started

Asked By 1300 points N/A Posted on -

My warm greetings to all, I am new to using windows live messenger, that is why I am posting here a problem I meet while using the application, I pasted below the whole screen shot of the error for better understanding of my problem.

Windows Live Mail

Windows Live Mail could not be started. Closing

Windows Live Mail. You calendar contains corrupt

 data that is forcing Windows Live Mail to close.


Since I am new with this application, the error message pasted above is so strange to me, I also consulted some friends about this, but they are also not familiar with the error message, so decided to post this issue here, in hope to get some advices and answers to my problem, I hope to hear from you all soon, thanks in advance.

Best Answer by jobethhenser
Best Answer
Best Answer
Answered By 5 points N/A #122951

My Windows Live Mail could not be started


Hi good day this error due to the mismatched version that was setup on your system, to resolve this kind of issue you need to go to the Microsoft website and update the corrupted files or you can update the downloaded application that is windows live essentials 2011 by going in to the Microsoft live update option from the start up menu and select the proper application that you want to update and the problem will solve.


Please refer of this link:




Answered By 0 points N/A #122953

My Windows Live Mail could not be started

  • The error indicates either a corrupt installation or damage in the registry that is associated with the program. The program might be successfully installed but it is still damaged.
  • Try repairing the program via control panel or just simply running the installation wizard/setup. There could be two option that will be given. It is either repair or remove. Choose repair in an attempt to recover corrupt file associated with the program and let it fix for you.
  • The system clock would have an issue too if the above option didn't work. To resolve this, Go to Control Panel, click on Date, Language, and Region settings. Click the Change Time Zone and uncheck the box at Automatically adjust clock for daylight saving time.

Login/Register to Answer

Related Questions