Error Update with VSTO Add-in for Word

Asked By 0 points N/A Posted on -

Hello Recently I installed VSTO and tried to update a VSTO add-in for word.

I tried doing this without launching the VSTO automatic update.

Actually I didn’t have enough rights to install it. I actually wanted to update it instead of installing it again.

When I installed it for the first time it was done with VSTO installation from VS publish folder with administrator rights. To update it I copied.


MyWordAddin.dll.manifest From the publish folder to the app data folder where the add-in was installed. My problem starts when I want to open my word document that has been linked with the VSTO file. I am met with an error instead.

The screenshot of the error which is French is attached below:

Programme d'installation de la personnalisation Microsoft Office

Installation de la personnalisation Office

Une erreur s'est produite lors de I'installation.


De: file:///C:/Dev/OutilsMetier/VstoGestionClause/GestionClause/bin/Release/Gestion Clause.vsto

La personnalisation ne peut pas etre installe car une autre version est actuallement installe et ne peut pas etre mis a niveau depuis cet emplacement. pour cette version de la personnalisation, utilisez d'aboard ajouter ou supprimer des programmes pour deinstaller ce programme : GestionClause. puis installez la nouvelle personnalisation depuis I'employment suitvant : file:///C:/Dev/OutilsMetier/VstoGestionClause/GestionClause/bin/Release/GestionClause.vsto

Details > Fermer

It reads that there is already another version which is installed.

Regardless of this error, When I launch my word document again and again the error disappears.

Can anyone please guide me why am I getting this error on the first attempt.

Your suggestions are needed to fix this up.

Your help will be highly praised Kind regards John

Answered By 10 points N/A #138726

Error Update with VSTO Add-in for Word


Hello Willie,

It is possible that you already have another version of that application installed on your system, and therefore it is clashing with the one you are trying to install right now.

You will need to do the following to fix the issue:

  • Check the control panel to see if you have another copy of the application installed there. If it is there you will need to uninstall it.
  • Also check the programs files to see if there is a VSTO add-in for word folder there are get rid of it.
  • Next you will need to install CCleaner on your computer and use to clear all the registry entries related to this application.
  • After that you can try installing it again. It should work perfectly this time round.

Hope this helps.



Login/Register to Answer

Related Questions