Device setting not applied for an aggregate device in Audition

Asked By 0 points N/A Posted on -


When creating an Aggregate Device in my Mac, Audition cannot attach, even though I’m only assigning the built-in microphone to it. From the audio hardware preferences screen, when I try to choose the Aggregate Device, Audition throws out this error:”The device in currently in use by another process”. I’ve tried closing every other program and tried assigning the device, but still the error persists. Can anyone please suggest what else I’m missing out and help me solve this problem? Thanking you for sharing your suggestions.

The device settings could not be applied because the following error


The device is currently in use by another process. Close other applications

and attempt to select the device again.

The last valid device settings will be used.

Answered By 577920 points N/A #178081

Device setting not applied for an aggregate device in Audition


This problem can be caused by your antivirus or if you have any other security applications like a firewall. When you see this error on your screen, close the application and restart your computer. Disable your antivirus after booting and start Audition again. See if this works. If you still get the “device in use” error, disable any firewall that you may have running on your machine and try again.

If the problem continues, remove the application, restart your computer, and install it back. If you are using an old version, it would also help if you upgrade to Adobe Audition CC 6.0 which requires Mac OS X 10.7 Lion and higher. You may also try updating your operating system to see if an update for Adobe Audition is available.

Click on the Apple menu on your desktop and select Software Update. Install the update on the next screen and wait until it is complete and then restart the computer. If you are prompted, enter your administrator username and password to continue. See if this works.

Login/Register to Answer

Related Questions