Add Font Resource failed on AVS video

Asked By 20 points N/A Posted on -

Hello friends,

The download and installation of AVS video went perfect without creating any error. But the error appeared when I tried to setup the AVS. The error message pops up with the following message. I tried all the option in the error message, but everything seems to do same job. I am not able to setup the program. How do I ignore or stop the error message? Please help.

AddFontResource failed.

Click Retry to try again, Ignore to proceed anyway, or Abort to cancel installation.

Answered By 574115 points N/A #192801

Add Font Resource failed on AVS video


Some users also experienced this error but were able to fix it using Sandboxie with AVS Video Editor. But first, try reinstalling the application because maybe a corrupted file caused the error. Uninstall AVS Video Editor and restart your computer. After that, click Start, All Programs, Accessories, System Tools, and select Disk Cleanup.

Select drive C and click OK. Check “Temporary files” and click OK to clean the drive. This will remove all the temporary files stored on your computer. Once finished, restart your computer and install AVS Video Editor again. See if it works. If it doesn’t work and you see the error again, download the latest version of Sandboxie and AVS Video Editor.

This fixes the problem on most of the users. To download Sandboxie, visit Download Sandboxie 4.08. This version works on both x86 and x64 Windows XP Service Pack 3, Windows Vista, Windows 7, Windows 8, and Windows 8.1. For the AVS Video Editor, visit AVS Video Editor 6.5. It supports Windows 2003, Windows XP, Windows Vista, Windows 7, Windows 8, and Windows 8.1.

Login/Register to Answer

Related Questions