No of visitors who read this post: 410
Category: Windows 7
Type: Question
No votes yet

Why is it that my Windows 7 wireless laptops are not working with my Cisco router? The technician from Cisco asked me to call my computer manufacturer because the problem is with my adapter. They said that the Atheros adapter needs to be updated. But I'm not sure if it is true since I was able to connect to a public WiFi hotspot with no problem.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 30306

Hi,

If you were able to connect to a WiFi hotspot with no problem then your ATHEROS wireless adapter is working. You just have to make sure that the CISCO router is configured to work with the modem from your ISP (Internet Service Provider). Can your laptop detect other wireless signals/networks? If it can, then you Atheros is not the problem since it's able to detect wireless signals and with this reasoning you can call CISCO again.

Here are things that you can try as well.

If your laptop shows connected to your CISCO network, then try to disconnect and re-connect.

  • Try to remove your network from your preferred network list (NETWORK AND SHARING CENTER - MANAGE WIRELESS NETWORKS-REMOVE CISCO NETWORK). Then go back and try to connect to a network again and if your own network is on the list try to connect.
  • Try to ping a website (ping http://in.yahoo.com/?p=us)
  • If its 0% loss on the ping then checks for other possible issues:
  • Check TCP/IP settings, it should be set to the right configuration depending on your ISP (automatic-DHCP or static).
  • Check for proxies on your browser, no proxy should be set. 
  • Try to turn off firewall as well.
  • If it will give you 100% loss, then here is what you can try;
  • Connect your laptop directly to the modem via Ethernet cable, bypassing the router.
  • If you are able to connect then call CISCO and tell them you are getting a 100% on the ping with the router connected and that you are able to connect when the router is bypassed.
  • If you cannot connect then it's time to call your ISP (Internet Service Provider). Its not your router nor your Atheros is the issue but your ISP.

# Comment Id: 114896

Following methods surely help you.
 
1. First power off your modem, router and desktop/laptop.
2. Update the drivers for your wireless network adapter via Windows Update.
3. Please use “Windows Connect Now” or "WiFi Protected Setup”.
4. Please ensure that both your wireless router and network adapter support WPA or WPA2 protocol, If you are trying to use this protocol.
5. Lastly you can call the support of your router manufacturer.