Saving changes is not permitted

Asked By 30 points N/A Posted on -

When I try to alter any object in any database by using Microsoft SQL Management Studio, I get the following error message.

Could you help me in this regard, please?



Saving changes is not permitted. The changes you have made require the following tables to be dropped and re-created.

You have either made changes to a table that can't be re-created or enabled the option Prevent saving changes that require the table to be re-created.


Best Answer by Devin_Moores
Best Answer
Best Answer
Answered By 0 points N/A #106240

Saving changes is not permitted


Dear Simon

Instead of using Design feature of SQL Server Management Studio (SSMS) use the T-SQL. It may be possible that you might have changed few settings to the table insertions. Somehow SSMS takes different modules of displaying warning message and stops the end user from going further, and it will be resulted in preventing hanging of SSMS. I know that this feature can cause inconvenience in a situation when someone is required to save table using SSMS. When this kind of situation arises, then I would recommend to turn off this feature by going to Menu >> Tools >> Options >> Designers >> Uncheck “Prevent Saving changes that require table re-creation”.

Hope this solution will be helpful for you.


Answered By 0 points N/A #195709

Saving changes is not permitted



Once upon a time this problem is giving me lots of bothering. When I need to do some changes to table or something I had to re create the table with new modifications. Like that I have re created same tables many times.

Then I found this solution for that.

Go to Tools from you menu bar.

Then Option in that menu.

Now you can see a new window has opened.

In that window you can see a main menu called Designers.

Under that one there is a sub menu called Table and Database Designer. Select it.

Then remove the tick of Prevent Saving Changes that require table re-creation.

Press OK.

Answered By 40 points N/A #106241

Saving changes is not permitted


Hi Helenmarmstead,

You get that error because one of the following reasons:

–      You add a new column into the middle of table

–      Or you change a NULL column

–      Or you change the data type of a column

–      Or you change the orders of columns

–      Or you drop a column

In order to fix that error, do following step: go to Menu Tools > Options > Designers > uncheck the check box “Prevent saving changes that require table re-creation”

Hope this helps.

Login/Register to Answer

Related Questions