RegScs.exe error while installing Microsoft .Net Framework 1.1

Asked By 0 points N/A Posted on -
qa-featured

I have a desktop PC running windows XP Pro. I have tried to install the Microsoft .net Framework version 1.1 without success. I first tried to install it as an update from the Microsoft site without success.

Later, I decided to download the setup and install it manually. The installation started off well enough but on finishing it gave me an error saying, "Application had generated an exception that could not be handled." See the error below:

“RegScs.exe – Common Language Runtime Debugging Services

Application has generated an exception that could not be handled.

Processid=0x18a8 (6312), Thread id=0xef4 (3828).

Click OK to terminate the application.

Click CANCEL to debug the application.”

Given the option of clicking Cancel or OK I decided to click OK from which I got the message that I had no debugger installed in my machine.

Clicking on Cancel rolled back my installation. Has anyone experienced such an error before?

How should I solve this problem appropriately ?

SHARE
Best Answer by Patrick03
Answered By 0 points N/A #81718

RegScs.exe error while installing Microsoft .Net Framework 1.1

qa-featured

Such an error usually occurs on Vista users, but let’s give it a try. Is it your first time to install the Microsoft .Net Framework 1.1?

I’m asking that because I’d like you to check if you can find the same version or other versions of the Microsoft .Net Framework on your Add/Remove Programs.

  • If you can find one before you go on with the installation process, please run the .Net Cleanup Tool. You can always download the Cleanup Tool. By running that, it would clean up the previous installation you did that failed.
  • Then try to run the .Net Framework 1.1installer again. If it doesn’t work when doing it automatically, try saving the dotnetfx.exe first and run it manually. Make sure that the file is saved with .exe extension, it should be executable.
  • If it still didn’t work for you. Repeat the process but this time, please make sure to run everything as Administrator. Before running the Cleanup Tool and the installer, Right click on the file> Run as Administrator. See if it helps this time.
Best Answer
Best Answer
Answered By 0 points N/A #81719

RegScs.exe error while installing Microsoft .Net Framework 1.1

qa-featured

The meaning of this message is that you have a debugger available on the machine that has crashed.

So in order to solve this matter, you should click Cancel and load the debugger to determine where it crashed.

You have to be armed with serious programming knowledge to debug the issues and this can be really painful. I will provide you with a very simple way to overcome this issue easily.

However, this method deals with the Windows registry; therefore make sure that you follow these steps accurately and carefully. For safety, it’s better to back up the registry before modifying it. If a problem occurs you can restore the registry.

1. Remove the .Net Frame works using Add or Remove Programs.  

  • Click Start >Run >type appwiz.cpl and click OK.
  • In the list of programs, select Microsoft .Net Frameworks 1.1 and click Change/Remove and click Yes.

2. Find and delete registry entries related to the .Net Frameworks 1.1.

  • Click Start >Run> type regedit and select HKEY_LOCAL_MACHINESOFTWAREMicrosoft.NET Framework, HKEY_LOCAL_MACHINESOFTWAREMicrosoft.NET Framework Setup and delete them.

3. Delete Files and Folders.

4. Click Start >Run> type system32, search for URTTemp file, Mscoree.dll and delete them.

5. Click Start>Run>typemsiexec /unregister, and click ok.Click Start>Run>typemsiexec /regserver, and click OK. Reboot the Computer.

6. Step 4: Reinstall the .NET Framework 1.1.

Visit the following site and follow instructions to install .NET Framework 1

Login/Register to Answer

Related Questions