No of visitors who read this post: 463
Category: Hard Drives
Type: Question
Author: Anonymous
No votes yet

When I try to remove the pen drive via the safely remove hardware option, it gives me an error which shows: “Generic volume cannot be stopped right now”. I'm afraid my pen drive might be damaged if it would be removed without properly stopping the Generic volume.

What should I do to solve this problem?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 23122

Dear Friend!
 
You are right. If you tried to remove your pen drive without using the safely remove hardware option, your pen drive could get damaged or corrupted. So, this is the reason why this error message appears when you have an application running from your pen drive. Or it may be because some files or documents are opened when you tried to remove your drive.
 
You should know that some files on your pen drive could be in use by some other programs in your computer. So, close all such types of files or applications and then, try removing the drive. If it does not work, then, also know that sometimes you have no application running from your pen drive or there isn't any file opened in your computer.
 
But if still, when you try to remove the pen drive it shows this error message, “Generic volume cannot be stopped right now”, in that case, you could use a free application called "Unlocker" which will help you to remove your pen drive from your computer.
 
Hope this helps.

# Comment Id: 23123

  • You might have removed the pen drive without properly shutting down, therefore you got this issue. But even if it is properly shut down and you still got the issue, it already needs to be looked into.
  • Probably, restarting the system with your pen drive connected can solve this issue.
  • Or if you have copied or deleted any file in the USB stick then, it's better to remove or close all the temporary files that are created while copying.
  • Also, delete the files from the Recycle Bin before shutting down the USB drive. This will definitely close the issue you are getting.
  • I have seen so many posts but there is no proper answer. Please let me know if your problem is solved.

Thanks,

HarryBalm

# Comment Id: 23124

This problem occurs when the pen drive is in use or some program in the pen drive is running. It's possible that a file manager which keeps running causes this problem. To get rid of this problem, follow these steps:

  1. Usually, waiting for some time solves the problem. So, wait first for a few moments and then try to stop the pen drive.
  2. If step 1 did not work, then, try closing all the running programs one by one until you find the one that is causing the problem.
  3. Another way is to download an additional program (USB safely remove), and after using that program, remove the pen drive.

Hope this helps.

Best of luck.