Problem with MySQL 5.X after reinstall

Asked By 50 points N/A Posted on -
qa-featured

How can I resolve this problem with MySQL 5.X?

After I trying to reinstall MySQL 5.X, I have seen this message.

MySQL Server 5.1

MySQI Server Instance Configuration Wizard

MySQL Server Instance Configuration

Configure the MySQL Server 5.1 server instance.

Processing configuration

Prepare configuration

Write configuration file (C:Program FilesMySQLMySQL Server 5.1my.in)

Start service

Apply security settings

Cannot create Windows service for MYSQI. Erro: 0

< Back Execute Cancel

 

SHARE
Answered By 0 points N/A #101839

Problem with MySQL 5.X after reinstall

qa-featured

Hi there Denzel,

You haven’t mentioned what windows version you are using, but for the sanity’s sake, I’m guessing you are using windows 7. From the top of my head, I can imagine there might be 2 possible reasons for your situation. I will try to explain them both.

Scenario One: Your MySQL was running smooth, then gone bad while re-installing.

Possible Reason: MySQL services has been installed and started already before the installation instance could create/save the configuration.

Solution One:

1) Click on Start > All Programs > MySQL > MySQL Server 5.x > MySQL Server Instance Config Wizard.

2) Click next and select the option “Remove Instance”, and then follow accordingly and complete the process.

3) Start the Config Wizard again by following step 1, But this time select the option “Configure Instance with Standard Configuration”. Complete the whole setup again. It should fix your issue.

Alternate to Solution One(If you prefer deleting the service without uninstalling):

1) Start > cmd to start up the command prompt.

2) Type “sc delete mysql” (of course without the quotation marks).

3) Then start the config wizard again as mentioned in the above step 3.

It should have fixed your issue. If it doesn’t solve your problem, then this is more likely a firewall issue.

Scenario Two: Your MySQL never successfully ran in your system or some/any update of your windows operating system, overridden some/any previous system settings.

Possible Reason:  Firewall is blocking the service to broadcast and being able to be connected to.

Solution Two:

1) If you have any third party firewall installed, make sure you are allowing incoming port 3306.

2) If your windows 7 firewall is on, then Start > Control  Panel > System and Security > Windows Firewall > Advanced Settings > Inbound Rules > New Rules.

Control panel Windows Firewall

 

Advanced Setting New Inbound Rule Wizard

3) Select Port and then click Next.

Port

4) Select TCP Then Specific local ports. Type 3306 in the text field as shown in attached image-004. Then click Next.

Windows Firewall with Advanced Security

5) Click Next.

6) Check Domain, Private, Public  any or all depending your needs. Click Next.

7) Give it a Name and  Description Click Finish.

Hopefully this will resolve your issue.

 

Login/Register to Answer

Related Questions