No of visitors who read this post: 1089
Type: Question
Your rating: None Average: 5 (1 vote)

I have installed Photoshop CS5 for image editing. But when I try to open an image file using the Photoshop CS5 application, the image does not open. A look at the layers and filters of the image indicates everything is ok but still the image won’t appear on screen. As an attempt to deal with the problem I try closing the Photoshop CS5 application and then reopening. An error message informs me the Photoshop CS5 application is not working. Although the same problem of failing to show image on screen occur with illustrator, this works fine after closing and reopening unlike the Photoshop CS5 application. Someone please help me on how to deal with the problem.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 45204

There are bugs most of the 64bit softwares. I bet the Adobe Photoshop CS5 you use was a 64bit. It would be advisable that you use a 32 bit Adobe Photoshop versions so that it will work on your computer. If not, you may change your OS for the sake that you can use your Adobe Photoshop CS5. In installing software, it is most important that you consider inspecting the compatibility of your OS to the software you want to install. So, that's it. Only those to solutions that i gave you are the best solution for your problem.

# Comment Id: 45218

Hi.

Maybe you have installed a corrupt Adobe Photoshop CS5. You need to reinstall it again. During the installation, there are supported files that you have to obtain. 

If you select the files, then it will install properly. But if you skip on any of it, the error will occur. Try to redownload it from the Adobe page or purchase a premium copy. Premium copy will maintain all supported files.

Thanks

# Comment Id: 52845

I tried to reinstall the Photoshop CS5 again and look on its detailed specification if my OS is compatible with it. And its working now. Thanks for reminding me Joy. Thanks guys...