How to enable Regedit when disabled by Administrator?

Asked By 0 points N/A Posted on -

When I try to edit my registry to correct some errors, I could not open the Registry Editor window.

I am having error that the Registry editing has been disabled by Administrator.

I did not disable it and never use it for quite some time now.

I am running a Windows XP SP3. Everything is up to date. I already run my antivirus, but no threat found.

How can I enable my Registry Editor again?

Thanks in advance.


Best Answer by cristy brown
Best Answer
Best Answer
Answered By 0 points N/A #98577

How to enable Regedit when disabled by Administrator?


Did you happen to have a virus attack prior to this? Many times, a virus, Trojan or spyware usually disabled Registry Editor. Are you using a computer owned by a workgroup or office computer?

Sometimes the computer Administrator put a restriction on using this feature to keep their employees from changing things and settings.  If this is the case, better consult the Administrator first.

However, if you are the using a personal computer or the Administrator of your own PC, there are steps and methods to follow to enable your Registry Editor again. 

Method 1. Enable Registry Editor by using VBScript.

  • Download Registry tools VBScript on Doug Knox (the one who created a VBScript to enable or disable the Registry Editor) page. He wrote a Visual Basic Script to do this:


             If this didn’t fix the issue try Method 2.

Method 2. Rename to regedit.exe

  • If your computers have been attacked by a virus or malware, they will load that is many times a zero byte dummy or fake file.  So if you type regedit in the run line, it will run the instead of regedit.exe file.

              Delete the to have access again to regedit.exe

Method 3. Windows XP Pro and Group Policy Editor

If you are running Windows XP Professional and can access it as the Administrator, you can have access to change the registry editor options in the Group Policy Editor.

1. Click Start and then Run

2. Type gpedit.msc and press Enter

3. Go to the following:

          User Configuration

          Administrative Templates


4. Find the option Prevent Access to Registry Editing Tools on the settings window.

5. If you find it, double-click it to change and then select Disabled or Not Configured and then click OK

6. Restart your computer

7. Try to open the Registry Editor again.

Answered By 0 points N/A #98578

How to enable Regedit when disabled by Administrator?


This trick worked for me. Thank you for your time and effort helping me. You are great!

Login/Register to Answer

Related Questions