Getting An Error Indexoutofrangeexception When Using Appstylist For

Asked By 30 points N/A Posted on -

I get an error “IndexOutOfRangeException” when opening the standard wsl file called InfragisticStyleLibrary.wsl.

I used AppStylist for ASP.Net to open the file.

I tried uninstalling the software and reinstalling it, but the problem still persists.

Did anyone experience the same problem, and do you have a solution to this issue?

The attached image shows the exact error I received when opening the file.


Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately.

Index was outside the bounds of the array.

Best Answer by Carl Jack
Answered By 0 points N/A #154097


I have faced many times to this error. If you have been provided the codes I able to show you what is the exact point that giving this error. But since you did not provide it I can not say where the exact place is. Anyway I am sure you have defined an array or some kind of a data structure there. Thai is the point you getting this error. When the program is loading there may be some values which are going to fill that array or data structure. But the it going to fill in undefined position in array. That is why you are getting this error.

See the figure below. May be you are going to add value the 6th 7th … etc. positions. So those are not defined.


Best Answer
Best Answer
Answered By 0 points N/A #154098

Hello Jonathan,

If you have already tried reinstalling the application and after that you are still getting the same issue, then it is most probable that the error is due to the following reasons:

  • The setup application is corrupt and therefore even trying a reinstalling using it won't help. You will just need to go and download another setup application and then use it for installation.
  • Make sure that you download the setup from a site that is trusted.

Otherwise, you will need to download and install the following update and see if that will help resolve the issue:

Hope this helps.




Login/Register to Answer

Related Questions