Error shown while installing HAP on a vanilla server 2008

Asked By 60 points N/A Posted on -
qa-featured

Hi to all,

Yesterday, I found an ample set of instructions on the internet about how to install HAP on a vanilla server 2008 with >NET4 and IIS7.

Following these instructions, I successfully started the installation, but I faced an error when I reached step 28. The step was to double click on the IIS authentication, but unfortunately I got an error.

The screenshot of the error is attached below:

It reads as:

Authentication.

There was an error while performing this operation.
Details:
Filename \?C:inetpubwwwrootHAPweb.config
Line number: 242
Error: The configuration section 'standardEndpoints' cannot be read because it is missing a section declaration

I surfed through the internet and found a similar problem with the nested .NET 2.0 applications, but in my system, I have all my application tools configured to use version 4.

Can anyone please guide me what as to the problem might be? I have searched a lot, but found no solution. Let me tell you one thing that step 21 was not applicable in my case. So, I ran icacls c:inetpubwwwroot /grant "IIS APPPOOLHAP"(OI)(CI)(RX) and added the permissions afterwards.

Does the problem has anything to do with my OS? I am using OS Unix.

Waiting for your helpful suggestions.

Thanks and best wishes.

SHARE
Answered By 0 points N/A #142608

Error shown while installing HAP on a vanilla server 2008

qa-featured

Hi,

You can use IIS 'application pools' to force specific sites to run in a specific .NET version. By using .NET 3.5, you can change the default application or if you want, you can create a specific application pool for WMS. A specific pool is needed to run multiple web site applications.

From IIS Manager, Right-click 'Application Pools' and choose 'Add Application Pool'

Give a name of the application pool and select .NET framework version: 2.0.50727 (=in fact Framework 3.5)

Then select the WMS web site and select 'Basic Setting'

Press Select in the 'Edit application' window and select the application pool from the drop-down list that you have just created now.

Click OK.

I think your problem is solved.

Hathy

 

Login/Register to Answer

Related Questions