Data transfer problems through RF

Asked By 40 points N/A Posted on -
qa-featured

I am getting some issues while transferring some data from one of module e e of my datalogger project to another module e e through RF. As you can see on the screenshot picture below, the RxModule could not establish any signal from TxModule even when I tried with different frequencies.

The connection has been tested in SmartRF Studio 7 as shown in the image. I have been trying for 3 days in getting a connection but I have no idea why I am unable to do so because the RF Part on the design is completely copied out of the application notes.

By the way, the TxModule was running when I took this screenshot.

The datalogger that I use is the CC430F6137. The EM430F6137-900 development board is the transmitter Module while the receiver Module is my self designed datalogger board. I followed all the given Design in SLAU278 known as the Typical Application Circuit CC430F61xx but still I am not getting any connection.

However when I tried to use the two EM430F6137-900 boards, I am finally getting a signal.

Therefore I conclude that there is no issue on  the part of my development board but with my datalogger board only.

If the problem is on my datalogger board only, how can I able to fix this?

Do you agree with me that there is no issue on The EM430F6137-900 development board?

Thank you.

SHARE
Answered By 0 points N/A #90423

Data transfer problems through RF

qa-featured
  1. Have you tried using different frequencies? If not then the first thing you have to do is to change the frequency and use a number of pair of frequencies with each other.
  2. Check to see that both the modules that are involved in the transferring of data are in working state.
  3. Just try sending any random data from one module to another. This will make sure that the modules are working and that the data is transferring successfully without any problem. It will also let you know that there is something wrong with your data if the sample data gets transferred and the original data gets the error.
  4. Once done, restart the application, re define both the modules and then try the transfer.

Login/Register to Answer

Related Questions