No of visitors who read this post: 751
Category: OS
Type: Question
No votes yet

I have a computer with Windows 7 and Ubuntu dual booting. After an upgrade of the Ubuntu to the newest version, my cursor just disappeared and cannot be viewed on the desktop when using Ubuntu. This problem is not there when using windows 7. Why does the cursor fail to appear when using Ubuntu. How can I rectify this?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 45383

Maybe what you mean by cursor is the mouse pointer. If your mouse pointer suddenly disappeared after you upgraded Ubuntu, maybe it got affected by the upgrading process. It is possible that while you are upgrading it the system encountered an error along the way. Check your hard drive for any possible errors using a disk utility application. If you don’t have one installed, use Ubuntu’s disk check tool to check the hard drive if it has any.

You may also try uninstalling and reinstalling the mouse from the Device Manager. Since the problem is only with Ubuntu and there is no problem using the other operating system, Windows 7, then it is clear enough that the problem originated when you tried upgrading it. Try restoring Ubuntu to its previous version if uninstalling and reinstalling the mouse failed.

Regards
Sharath Reddy

# Comment Id: 45388

Hello, there are several ways to solve your issue. I hope one of them will work for you. These are given below:

1. You can try changing your cursor theme, in order to figure out if the problem exists with the current theme only. To change the cursor theme settings you can use the "Gnome Tweak Tool" or "Dcof Editor". You can choose between "Software Centre" or "Sudo apt-get" to install either of the softwares. In "Gnome Tweak Tool" to change cursor settings go to "Theme page" and click "cursor theme".  If you are using "Dconf Editor"  goto "org -> gnome -> interface -> cursor-size".  To better understand the process you can see this video :

You can also try to change your DMZ theme from DMZ-White to whiteglass. You have the option to change it to any DMZ theme and it might work. In order to change  go to, "edit /usr/share/icons/default/index.theme ". Non-DMZ themes can be found in "usr/share/icons " in a cursor directory which will have subdirectories with all the themes.

You can try editing your xorg.conf using the following method.The code will be :

gksu gedit /etc/X11/xorg.conf

here add this line to the Device section

Option "HWCursor" "False"

Here is an example:

Section "Device"

Identifier "Configured Video Device"

Driver "driver"

Option "HWCursor" "False"

EndSection

Save the file and press Ctrl+Alt+Backspace to restart the x server.

Alternatively, you can set SWCursor in your xorg configuration. You need to edit the file "xorg.conf". In order to edit press "alt+f2" while running  "gksu gedit /etc/X11/xorg.conf". However if you are using Kubuntu you need to replace "gksu gedit" with "kdesu kate". The code will be added as fol :Code:

Section “Device”

Identifier “Configured Video Device”

Option “ActiveDevice” “LCD, CRT”

Option “SWCursor” “on”

EndSection

# Comment Id: 53007

Hi

Never thought of the error that may have been occured during the installation. Thanks for giving me the idea Sharathr.Doing all what you've said my cursor/mouse pointer is now ok. Great site techyv!