Configure the TS Gateway with error “the logon attempt failed”

Asked By 0 points N/A Posted on -
qa-featured

I need someone to help me figure out why the TS gateway we have been using to enable our employees gain remote access for quite some time is no longer functional. All users trying to gain access through the TS gateway are denied even if the user credentials are right and the message “the logon attempt failed” is displayed. The employees have the option of connecting to a terminal server Pc or going to the company’s website and launching a TS remote application which are both routed through a TS gateway. The system has been running efficiently until today. This is a serious situation that needs to be solved urgently.

SHARE
Answered By 0 points N/A #107590

Configure the TS Gateway with error “the logon attempt failed”

qa-featured

This problem has been plaguing me for months on an SBS 2008 machine, but has never been critical enough to go to crazy measures to fix.

After resorting to uninstalling and reinstalling the TS Gateway service and it still not working, I went to IIS Manager → Sites → SBS Web Applications → Rpc → Authentication and found only "Basic Authentication" was enabled.

Though details on this particular error are scarce online, I have seen that Outlook Anywhere seems to change IIS Authentication schemes. Since this is SBS, I figured Exchange and TS Gateway might be fighting over the authentication setting.

I enabled "Windows Authentication" then ran an IIS reset. When IIS came back online, I was able to connect via TS Gateway to two servers and at least one workstation. I connected and disconnected multiple times and it had no problems.

I can't guarantee this is permanent, but I'm definitely hoping.

Login/Register to Answer

Related Questions