No of visitors who read this post: 3999
Category: Printers
Type: Question
Author: Redkey25
No votes yet

I recently bought a Canon MP287 Printer.

I installed the driver using the installation disk that came along with the package on my computer that has Core i7 8.0G RAM 64-bit Operating System using Windows 7 Ultimate.  

I followed all the steps carefully everything else is working but the scanner.  

Whenever I try to scan documents, the computer gives me an error message that it cannot launch MP Navigator EX 4.0.  

By the way it works perfectly fine with my MacBook Pro.  

I tried re installing the driver several times but I still get the same problem, it there a solution to this?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 62978

Hi,

Please follow the steps to rectify the issue:

- Try scanning from WIA. Go to start, type scanners on the search box and select view scanners and cameras. Check if you can scan from there.

If you can scan, the problem is the software. If you can’t scan, there is a problem on your computer.

If you can scan follow these steps:

- Use Revo Uninstaller to uninstall canon software. Download from this link: http://www.revouninstaller.com/revo_uninstaller_free_download.html

- After removing the canon software, download the latest software and driver for your MP287. Click on the link: http://support-sg.canon-asia.com/contents/SG/EN/0100290801.html

- Install the software

Check if you can scan.

If you can’t scan from scanners and camera follow these steps:

- Go to start, type cmd on the search box then right click cmd and run as administrator.

- On the black window, type SFC /scannow

- The system file checker will check the windows files and will automatically fix it.

- Try scanning again

If it won’t work, check your firewall if its blocking the port for scanning if it’s wirelessly connected.

Hope you will find this helpful.

Cheers.

# Comment Id: 85027

Hello Redkey,

What you will need to do to resolve that issue is the following:

  • First, you will need to log off the account you are logged and then go back on to the administrator's account.
  • You will need to restart the computer and then start tapping F8 on the keyboard immediately.
  • A boot menu will come up where you will need to pick Safe mode with networking.
  • And then you will log into your account.
  • You should see a black desktop background as well as safe mode in all four corners of the screen to be sure that you're in safe mode.
  • After that you can try to open MP Navigator and see if it opens up.

Regards,

Carl