An unknown error occurred trying open a movie in QuickTime

Asked By 0 points N/A Posted on -

Hello Pro,

Whenever I try to open a movie in QuickTime I get this error message and it fails to play the movie. I thought that the QuickTime is corrupted so I tried to uninstall and reinstall the application. But this method did not solve my problem. I even tried to update the QuickTime player, but no luck. How do I fix the issue? Anyone else is facing the same problem? Please help. Thanks.

Error -1856: an unknown error occurred (

Answered By 590275 points N/A #192074

An unknown error occurred trying open a movie in QuickTime


The error 1856 that you received is a Carbon Apple Event error which is described in the following syntax:

  • handlerNotFoundErr = -1856, /* handler not found */

The documents from the Apple developer doesn’t say much about this error and if you happen to encounter this, there’s actually not much of a solution but to reinstall and hope that it works. Most of the users who are experiencing this error were all using x64 Microsoft Windows 7 and I think the architecture of the operating system has something to do with the error.

Unfortunately, there’s only one version of QuickTime that can be downloaded and its x86 or 32-bit but there’s no problem actually because this x86 version can be installed and supports x64 Windows 7. If you are not sure on the version you are using, download and install the latest version from QuickTime 7.7.5 for Windows. It supports Windows XP, Windows Vista, and Windows 7.

Try upgrading to the latest version and see if you can play the MOV file after this. If still not, just convert the file into another format like AVI for much compatibility. You may also try setting the program to always run as administrator. To do this, open Windows Explorer and go to the installation folder of QuickTime: C:Program Files (x86)QuickTime.

Right-click “QuickTimePlayer.exe”, select Properties, and then Compatibility tab. Find and check “Run as Administrator” and then click OK. This fixes the problem most of the time.

Login/Register to Answer

Related Questions