Error when playing Sim City 4

Asked By 0 points N/A Posted on -

I have set up SimCity 4 and it is working pretty well.

Then when I tried to play it an error message appears:


"Could not search the cd-room, please put it again and try"

if I eject the CD and put it back in again I get the same error. So I decided to uninstall the program and reboot the computer and setup the games once again and still I get the same error.. Is there someone who could help me? Why can’t it locate my CD-ROM?


Cannot locate the CD-ROM      
Please insert the correct CD-ROM, select OK and restart application      

Answered By 0 points N/A #102736

Error when playing Sim City 4



Maybe you do not have any virtual CD's loaded in your computer. This happened to one of my friends. BTW, Virtual CD players, if you have, are programs that allow you to play a cd with which is then converted into a file without the CD. You would need another program to create the file. A CD/DVD burning program can also install a Virtual CD drive to your computer.

Well, Microsoft has come up with a resolution for the “Please insert the correct CD-ROM” error.

Note: URL is working.

that’s the link…



Or, if all else fails, tryto use the disk 2. That should probably end your problem with the error


Login/Register to Answer

Related Questions