No of visitors who read this post: 2593
Category: Networking
Type: Question
Author: Athan haas
No votes yet

I am trying to download .net framework 4, and gets the error (0x800C0005). I tried downloading from the web and also tried the full setup but both gives the same error. Any suggestions?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

# Comment Id: 60252

Athan has

Hi,

I have faced the similar error 0x800C0005 once when I was trying to download one of the application update from Microsoft , and I had to research for a whole day to resolve the issue, but resolve I did, and found the actual reason for this error.

Actually this error occurs when some dynamic link library files (.dll) are not properly registered OR the second reason maybe when there is a FIREWALL which prevents HTTPS (SSL) connection.

Now in your case, as you mentioned that you also tried to run the full setup which failed, which means that the .dll files are NOT correctly registered. To resolve this issue, follow these steps:

·         Click on start – run – and type cmd, press enter

·         On the open command prompt type( without qoutation)  “regsvr32 Softpub.dll” press enter

·         Now type “regsvr32 Wintrust.dll”  press enter

·         Now type “regsvr32 Initpki.dll”  press enter

·         Press OK

This procedure will reregister several .dll file.

Restart your computer.

Your issue will be resolved now.

.

PT