Avast Internet Security blocking internet access

Asked By 35 points N/A Posted on -
qa-featured

Hello, I have recently updated my Avast Internet Security copy on one of my two laptops, a Lenovo Thinkpad with Windows 7. Now I find that, while the wireless icon confirms that I am connected to my network, there is the yellow circle indicating no connectivity. The other laptop has no issue. I tried ipcongif to no avail. I tried uninstalling Avast. I looked for possible programs that could be causing this. No solution in sight. What could be wrong? What should I try next?

SHARE
Answered By 0 points N/A #184141

Avast Internet Security blocking internet access

qa-featured

Hello,

This problem appears to some of the users. When an avast! The program is updating itself, this leads to restarting PC, without having any access over internet. Including some other programs as well, the Avast user interface won’t execute properly. This may arise because of a conflict between Zonealarm and Avast!. But there may be some more possible scenarios, like some other firewalls having the same issue.

The root of this issue is, when the Avast! Program files are updated, it is still not working until the computer gets rebooted. And hence when it happens, Zonealarm identifies about the file alteration and blocks them from internet access till administration “allows” it. As this all happens during start up process only, the user can’t allow them. Similarly, all of the avast! The shields are also barred from root access through avast!. On the other hand, there are some system functions, which have nothing to do with avast!, are not blocked, assumes normal connectivity of computer with internet. Hence finally as a result of this vicious circle, this problem occurs.

So, now talking about the possible workaround, the easiest solution will be to simply go to “safe mode” and stop the Avast! Service and restart normally. Steps:

  1. Login with your administrator login id.
  2. Go to Start<<control panel<< services Manager.
  3. Locate<< ‘Avast! Antivirus’ Service<< open and change the ‘startup type’ to ‘Manual’<< press ‘OK’. Restart.
  4. Now this time, you must be free to use your internet services normally. If it is still disabled, try these steps:
  5. Login with your administrator id
  6. Go back to ‘Services’.
  7. Go to the ‘Avast!’ service<< right click << select ‘Start’.
  8. Now you can see the “Zonealarm” pop-ups.
  9. Confirm the “Allow” for the Internet access for Avast!.
  10. Now reboot your system in safe mode
  11. Change back the Avast! Service from ‘Manual’ to ‘Automatic’. Do Reboot.

Now this time your issue must be fully resolved.

Login/Register to Answer

Related Questions