Xilinx error FTD2XX.dll is missing from computer

Asked By 30 points N/A Posted on -


I have this Xilinx error when I try to connect to server. I tried to solve this with a DLL fixer but still this error. I copied the DLL manually and still I didn’t get rid of it. Please someone help me with this DLL. How can it be solved?


The program can’t start because FTD2XX.dIl is missing from your

computer. Try reinstalling the program to fix this problem.


Best Answer by Aashish
Best Answer
Best Answer
Answered By 2090 points N/A #187271

Xilinx error FTD2XX.dll is missing from computer


Hello there,

This error message pops up when your Digilent Programming cable isn't connected and the required files were unable to be copied. To successfully run the applications from the network the cable must be connected. The first time you connect the cable there are files that will be be copied across. To solve the issue follow the below steps.

For Windows :-

  1. Connect the cable and make sure that The Digilent plug-in software and cable drivers are installed properly.
  2. Disconnect and cable and don't forget to check if you have administrator privileges.
  3. Type Cd (change directory) to <Xilinx install>digilent.
  4. Run install_digilent.exe and make sure that the installation wizard is completed.
  5. Reconnect the cable.

If the above solution fails try to uninstall the Digilent drivers completely. There are possibilities of conflict with Existing older versions of the drivers.

For Linux :-

The prerequisites for the Linux are that the libusb 1.0 package, the Adept run-time and ftdi drivers should have been installed before you attempt the installation process.

  1. Like Windows make sure that the Digilent Cable is physically connected to the machine for some files to be copied over before installation.
  2. Disconnect and cable and don't forget to check if you have administrator privileges.
  3. Create a /tmp/digilent_install directory.
  4. Copy the /<Xilinx install>/bin/lin(64)/digilent directory to the newly created /tmp/digilent_install.
  5. Install the Adept run-time software, run the install script with root/sudo permission. 

    cd digilent.adept.runtime*
    ./install.sh silent=1
    cd ..
  6. Install the ftdi drivers, run the install script with root/sudo permission

    cd ftdi*
    ./install.sh silent=1
    cd ..
  7. Install the plug-in software without root/sudo permission. 

    - cd libCseDigilent* - ./install.sh silent=1


  8. Install the libusb1.0 package (current version is 1.0.8), run the install script without root/sudo permission.

    cd ~
    tar xvf <directory containing downloaded LIBUSB archive>/libusb-1.0.8.tar
    cd libusb-1.0.8
    ./configure --prefix=/home/<username>/libusb1_<32 | 64> -- select 32 or 64 bit depending on your platform
    make install
    setenv LD_LIBRARY_PATH /home/<username>/libusb1_<32 | 64>/lib:$LD_LIBRARY_PAT

Hope you will find this helpful.

Answered By 590495 points N/A #187273

Xilinx error FTD2XX.dll is missing from computer


Since you are using an old version, you probably want to update to the latest version. Download and install Xilinx Vivado Design Suite 2014. Since Microsoft Windows has a limitation on the maximum amount of memory to use and only up to 2 GB is properly utilized, if you are using Windows XP, you need to enable the 3 GB support to address the requirement for Xilinx.

To enable the 3 GB feature, you need to edit the boot.ini file in the root of your system drive and add without quotes “/3GB” at the end of the “startup” line. But if you are using Windows XP Service Pack 1 and you added the “/3GB” switch, the operating system may not start without applying a patch from Microsoft.

So, to avoid this from happening, update your operating system to the latest Service Pack. Download and update to Windows XP Service Pack 3. This is the latest and last Service Pack for Windows XP. If you simply want to try and download the missing DLL file, download ftd2xx.dll Library File. Select the Manual Fix column to download the DLL file.

To install the file, unpack the ZIP file then copy the DLL file to the installation folder of the program requesting it. If this doesn’t work, copy the DLL file to “c:WINDOWSsystem32” and then see if this will work.

Related Questions