Unidentified Public Network on Windows 7

Asked By 210 points N/A Posted on -

Hi mates,

I have installed Windows 7 on my computer. It picked up my wired and wireless router, printer and other devices. The cable connection to the internet worked. Everything was working correctly. I removed the wireless router.

But now Windows 7 is not getting connected to any devices. It is giving an error message, “unidentified public network”.

I have tried everything to fix the problem. Broadband cable connection is not available. Please Help.

Thank you.

Best Answer by jessy_neil
Best Answer
Best Answer
Answered By 0 points N/A #129310

Unidentified Public Network on Windows 7


According to the error message, it clearly shows that the network does not have a valid IP address. The gateway it connects is The DNS server is not the device that includes the gateway. However, in the route table, you have manually added a route that connects to

In this case, I suggest that, you obtain the correct address of the router first. Then check the settings of the Local Area Network connection. Make sure that it obtains an IP and Default Gateway address automatically, and click the “Advanced” button ; delete all existing Default Gateway and DNS.

If the issue persists, please let us know if the computer is in a domain or a workgroup. If it is in domain, if there is any other DHCP server, that is hosted by Windows Server systems.

Answered By 0 points N/A #129311

Unidentified Public Network on Windows 7


To solve your problem you can check these steps:

  • Now put you wireless one end cable in the router first.
  • Now when putting the second cable to the PC see the following the light of the RJ45 blinks or not, if it blinks it mean that there is connectivity between the PC and router.
  • Now go to configure the router device.
  • Configure it as, first go to explorer and type and now a configuration page will appear.
  • Configure all your settings as your service provider tell you. When all done now click save.
  • Close the browser and then again open it typing some web address I hope it is now working. If still not working, then check your device for network.

I think after checking all you will be able to solve this problem.

Login/Register to Answer

Related Questions