Windows 8: Stuck at Loading Screen

Asked By 50 points N/A Posted on -

Hi experts, 

I'm in need of help. I am trying to find every possible solution to my problem and I was hoping I can get it fix here. I am running Windows 8 and got stucked with the loading screen.I tried resetting my CPU but I only get the Automatic Repair option which didn't help at all. I even tried to insert the Windows 8 Media disc and do the Repair option, however, when I pressed the button to start my computer from the Media disc, I only got a black screen with blinking cursor. Please help me.


Answered By 0 points N/A #169931

Windows 8: Stuck at Loading Screen


I will suggest that you disconnect all the USB devices or other peripheral connected to your computer and then restart your computer and see if you can be able to boot into your desktop again. If not, you need to run the bootable media again. Some users have tried running the media for how many times or until the media runs successfully. Another possible cause is your video driver. Can you start your system with the VGA only and check if there is anything wrong with that? Also, check on the boot order in your BIOS and set it to boot from the CD-ROM first.

Answered By 590335 points N/A #302197

Windows 8: Stuck at Loading Screen


If your computer got stuck on the loading screen when Windows is booting, try booting using the last known good configuration setting. Restart your computer again then press F8 before the Windows logo appears. In the “Advanced Boot Options” screen, select “Last known good configuration” and hit Enter to boot the computer.

If this did not work, shut down your computer completely by pressing and holding on the power button of the CPU to turn it off. Once the CPU is turned off, disconnect all devices from the USB port including your mouse and keyboard. After 10 to 20 seconds, turn on your CPU and see if it boots.

If this did not work either, press the reset button on your CPU to restart the computer then go to the BIOS. In the BIOS, go to the USB configuration and change the following settings:

  • Intel xHCI mode: Disabled
  • Legacy USB Support: Enabled

Save the settings and try booting again.

Login/Register to Answer

Related Questions