Windows 7 64-bit showing only 3 gig usable RAM

Asked By 10 points N/A Posted on -


I recently bought 4 gig of geil memory with heat sink and installed in my system. When I check the system properties, it shows that I can only use 3 gig or the installed ram. I also check the resource monitor and found out that 1 gig of my installed ram is under hardware reserve. Is there a way to solve this? thanks


Best Answer by GavinN
Best Answer
Best Answer
Answered By 0 points N/A #110788

Windows 7 64-bit showing only 3 gig usable RAM


It would be helpful if you mentioned your motherboard brand and model and the version of Windows you are using. 

However, based on what you posted, I'm assuming you are using a motherboard with onboard graphics.  And since Windows sees all 4GB of RAM then you are also using a 64-bit version of Windows.

The 1GB RAM under hardware reserve is the amount of RAM being used by your motherboard's onboard graphics.  Reduce the amount of RAM reserved for your onboard video through the BIOS or get a discrete PCI-E graphics card to reclaim some (or all) of that 1GB.

But my advice is for you to first observe if you are actually using up all 3GB of memory running your usual applications.  If 3GB seems enough for your needs then you can just leave your graphics memory setting as it is.

Answered By 10 points N/A #110789

Windows 7 64-bit showing only 3 gig usable RAM


Hello George,

When you install a RAM memory on to your computer, there is always that memory that is designated to be used by the computer system functions. Like on my computer, I have installed a 3 GB memory and about 300 MB has been designated to be used by the system functions.

The memory to be used by the system is not always that big, but in your case it seems like the system will be using a whole 1 GB of memory out of the 4 GB that you just installed, which is a little strange, but it could be possibly due to the programs you are running on your computer. If you running memory intensive programs like games and videos, then that could be the reason behind that.



Lee Hung

Login/Register to Answer

Related Questions