Windows 7 64-bit Problems with File Association

Asked By 7060 points N/A Posted on -


Even though I am able to go through the normal process to combine a program with an extension, it doesn't work. After going through the browse process and selecting the program it brings me back to the "open with" window.

The program I've selected does not show in the "open with" window and it appears that it is simply ignoring me. I've also tried the "Default Programs" route, but wind up at the same "open with" window that still ignores me. Suggestions? THANKS.

Best Answer by Glenn.R
Best Answer
Best Answer
Answered By 0 points N/A #79267

Windows 7 64-bit Problems with File Association



By default, the Open with option is not available with executable files. Try any of the methods provided below to resolve the issue:

Method 1: If Open with option is unavailable for all type of files

  1. Click the Start button.
  2. Select “All programs”, choose “Accessories” and open Notepad.
  3. Copy and paste the following in the Notepad:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT*shellexContextMenuHandlersOpen With]


  1. Click the “File” option and select “Save As” from the menu.
  2. Type "OpenWith.reg" (with quotes) in the Filename box and click “Save”.
  3. Open the folder where you have  saved the file and double click to open it.
  4. Click “Continue” and OK.
  5. Check whether the issue is resolved.

Method 2: Change the default program for a particular file extension

  1. Click the Start button.
  2. Type “Default Program” (without quotes) in the Search box and press Enter.
  3. Select “Associate a file type or protocol with a program” in the right panel of the window.
  4. Select to highlight the extension of the particular file from the list and click the “Change program…” button.
  5. Select a suitable program in the Open with windows and click “OK”.
  6. Click “Close”.

Hope this helps. Glenn

Login/Register to Answer

Related Questions