Video files Not Playing in Aegisub

Asked By 0 points N/A Posted on -

I am using Aegisub for arranging subtitles on my video files. Recently, when I tried to open it, I received an error stating:"ffmpegsource factory: FFmpegSource video provider: Couldn't find any video tracks: No suitable, indexed track found avisynth factory: AviSynth error: FFVideoSource: No video track found ".

I could not open my video. I tried to download the video files again and play it in Aegisub but it is still not working.

The files can be played in 001 alone, but to the rest such as 002, 003, 004, 005 etc. it is still not working.

Even if I convert it to .MP4, .AVI or .FLV, it still cannot be played.

I attached the picture of the error. I hope someone can help me resolve this problem.

Aegisub Error

DirectSoundPlayer2thread: Could not lock buffer for filling

Best Answer by momford
Best Answer
Best Answer
Answered By 10 points N/A #121394

Video files Not Playing in Aegisub


Here’s the statement on aegisub website.

The mantra is: Aegisub isn’t a media player; if you want a media player use a media player.

So, it will be better if you play the video using application that really designed for media playing such as VLC or Klite mega Codec

Download link for VLC

Download link for KMC

For the file with .001, .002, .003 extension you will need hjsplit to join those file.

Download link for hjsplit portable

Open hjsplit and then click join

Then you click input file and then choose file with .001 extension

Now, choose your destination folder or leave it as is

Then click start

Important note: your file with.001, .002, .003 and so on must be in the same folder

Hope it will help you

Answered By 15 points N/A #121395

Video files Not Playing in Aegisub


The workaround to that problem will involve forcing the Aegisub application to use a software OpenGL implementation instead of the that has been obtained from the supplier of your  graphics card driver.

But before you do that, I will suggest that first you try updating  the graphics card driver that you are using.

You will need to get the latest driver directly from the maker of your graphics chip, and they are majorly NVIDIA, ATI/AMD or Intel.

If otherwise, then you will need to look at the support site for your computer vendor to see if you can get the drivers from there.

The procedure for installing using OpenGL will be as follows:

  • First you will need to Download MesaGL 7.4.2 for Windows.
  • And then you will need to unpack the driver
  • And then run the aegisub32.exe file.
  • Aegisub will then use software rendering for the video display, which may be a bit slow but it will work in all cases.

Clair Charles

Login/Register to Answer

Related Questions