Usb 3.0 not working in windows 8, 8.1 and 10

Asked By 30 points N/A Posted on -

I have Kingston USB 3.0 which I used regularly without issues. However, after installing GTX 970, the rest of the drivers on my USB were corrupt. I tried to install a new Windows on the same USB and right after that, my USB won't work on my Windows 8 PC. I don't know what happened but is it possible to fix this? If yes, how?


Answered By 0 points N/A #189845

Usb 3.0 not working in windows 8, 8.1 and 10


Hello Raymond,

Here is the best answer to your question.

1. Simply reboot system will fix this problem but in many cases this will not be solved as easy as that. More than one (1) USB device connected might give you conflict in software and hardware. Better to disconnect one the external device to see what’s wrong.

2. You can also download driver-software for Kingston in their website to get full access in any of Kingston devices.

3. You need to update all running devices and programs, any third party software that causes any conflict.

4. Right click on “My Computer” or “Computer” and click “Manage.”

5. Select “Device Manager,” and look for USB controllers. Check if there’s “Exclamation or Arrow-Down” symbol that might be preventing you to access any USB ports.

6. Try to disable the device. Enable after few seconds and try to plug again USB device.

Login/Register to Answer

Related Questions