Unable to open HP utility icon after installing the 10.7 driver software

Asked By 0 points N/A Posted on -

Hello guys,

I have recently purchased an HP printer Envy 100. The system I am currently using is MacBook Air with OS X 10.7.

The driver CD that I got with the printer does not support  my OS.

So, I had to download the 10.7 driver software from the official HP website. Fortunately, I installed the software successfully without any trouble. Next step was to configure my printer for wireless printing.

So, I opened the system preferences and successfully configured it without any issues. I tested it by printing wirelessly, and it was awesome.

When I tried to open the HP utility icon, to my surprise, it would not open. It gave me the following error on the screen:

HP Utility cannot be opened because of a problem. Check with the developer to make sure HP Utility works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X.

Click Report to see more detailed information and send a report to Apple.

I tried clicking on the utility icon again and again, but the same error persisted. 

Does anyone has a clue as to why this is happening?

I tried by all means to resolve the issue, but of no use. Your help is needed in solving the problem. 

Waiting for your replies.


Answered By 5 points N/A #142233

Unable to open HP utility icon after installing the 10.7 driver software


Ok. The problem here is that you are using older version of HP utility. So you need to make or look for higher version from the internet to fix the error. You need to download HP utility version 5.2.0 which will work fine to your MacBook Air with OS X 10.7.  Usually, you may need also to re-install everything, but since you said that others work fine you may do this step.

1. Download the disk image of HP utility version 5.2.0

2. Ctrl+click on the HP Installer icon to view contextual menu

3. Click "Show Package Contents"

4. Select Contents > Packages > HP Utility

5. Double-click the HP Utility package then follow the installer steps.

Hope it will solve your problem.

Login/Register to Answer

Related Questions