Unable to install the Intel Rapid Share Technology software

Asked By 20 points N/A Posted on -


Hello friends,

I have recently purchased an asus system. I tried to install the Intel Rapid Share Technology software on my system, but unfortunately, I was met with an error on my screen. The screenshot of the error is as follows:



This computer does not meet the minimum requirements for installing the software.

The system I am using has a P8Z77-VLX motherboard with 120 GB ram and intel 520 series 2.5" solid state drivers (SSD). I am running OS windows 7 64 bit.

I don’t get the point as to why am I getting this error? I have also tried to set the SATA controller to RAID and AHCL, but I got the same error twice. I have no idea of how to solve the problem.

Your guidance is required in this regard. Please do let me know, if you have a solution.

Any ideas are most welcome. Anxiously waiting for your views.

Kind regards.

Answered By 0 points N/A #141822

Unable to install the Intel Rapid Share Technology software


        For you to be able to install the Rapid Share Technology software on your system, you need to set AHCI or RAID mode to your BIOS and re-install the system (I think you need to know what is RAID. You need to be technical with that topic.). Installing operating system needs that the appropriate F6 drivers are already loaded during the operating system installation. So the instruction are,

1. Set your BIOS to RAID or AHCI

2. Then re-install the operating system loading the drivers that I mentioned (appropriate F6 drivers). 

So id you do that successfully,  by that time you install Rapid Share Technology software, you will not encounter that error. Just make that you will follow my instruction regarding to your BIOS. Good luck.


Login/Register to Answer

Related Questions