Trouble Installing Civilization III CD

Asked By 0 points N/A Posted on -


Good day.

I own a Civilization III CD, I tried to pose the brave in my laptop but the testament does want to install. What appears is " I/O happening 23". Then I am given 3 choices: "abort, hear, and take". I tried to disabled my Norton Antivirus auto detect and private firewall but I still  got the same unvaried error. What do you think is the problem?

Can somebody have suggestion about this? Any help is much appreciated.

Answered By 0 points N/A #144498

Trouble Installing Civilization III CD




I/O device error usually occurs when you have a CD/DVD that is either scratched or damaged. Please check your CD/DVD, you could actually use a toothpaste or alcohol to clean it with soft cloth. If this won’t work, there could be a hardware or connection issue, try this following:

1.       Restart/Shutdown the computer normally.

2.       Retry accessing the disk drive.

3.       If there is still error, try opening the CD/DVD on another computer

4.       If it opens in another computer, there is actually an error in hardware connection. Try to unplug and plug the connectors between the disk drive and the motherboard.


Last resort is to try to download PowerISO or other application for virtual disc. Copy the image of the disc using PowerISO then mount it on your virtual drive.

I hope this helps.

Login/Register to Answer

Related Questions