There was a problem starting LogiLDA.dll on my new Windows 8.1

Asked By 0 points N/A Posted on -

Hi All,

On my Windows 8.1 machine i get this error There was a problem starting LogiLDA.dll.

I read on a site to delete it, and now i get this.

"Cannot find C:windowssystem32LogiLDA.dll"

Even after restoring i still get the same issue and would be great if i get the solutions for both the issues

Best Answer by Ruby Islam
Best Answer
Best Answer
Answered By 70 points N/A #89697

There was a problem starting LogiLDA.dll on my new Windows 8.1


Hello Sayansaam,

You have deleted a system file. You should not have done this. There are many techniques online that tells many ways. But whatever it says, don’t attempt to delete any file from the “System32” folder.

As you have deleted, now Windows is requiring this file. As it is missing, it is showing up error message.

Download the DLL file. Copy it into the directory “C:windowssystem32”. Then, from the start menu, type “cmd”. Run “cmd.exe” as administrator and run the following command:

regsvr32 LogiLDA.dll

Then restart your PC.

If that doesn’t solve your issue, you might have to re-install Windows.

Answered By 15 points N/A #198935

There was a problem starting LogiLDA.dll on my new Windows 8.1

It seems that you are using a Logitech mouse or trackball with the Unified Logitech Dongle.
These steps should fix the error:
1. Insert your Unified Logitech Dongle into any open USB port on your computer where the LogiLDA.dll error is generated.
2. Your computer should recognize the Unified Logitech Dongle and loads the appropriate software.
3. Verify that your mouse or trackball works through the Unified Logitech Dongle.
4. If yes then restart your system.
The problem should be solved already.
Answered By 574115 points N/A #89699

There was a problem starting LogiLDA.dll on my new Windows 8.1


Actually, the best way of fixing this error is to find out which program is actually using the DLL file because you only need to reinstall it to fix the problem. But the problem is, you cannot just check on the path of the missing DLL file to find which program is accessing it. If the error appears immediately after starting Windows and it happens all the time then the program accessing the DLL file is really in the Windows Startup.

You can either disable the program in the Windows Startup or uninstall it if you learn which program is it. After checking, it seems that the error only appears after installing a Logitech driver and it mostly happens on Windows 7 and Windows 8. When you install the Logitech driver it will also install the Logitech Download Assistant which supposedly helps you automatically download recent Logitech updates.

It runs automatically during the startup and that’s how the error is committed. Mostly, the error appears after the assistant updates something. The error may also appear if in case you installed the Logitech program in a different drive instead of the default drive C and also if the Logitech security certificate expires.

Try first fixing the security certificate in case it has already expired. To do this, go to Control Panel, Device Manager, and then expand Human Interface Devices [HID]. Find and double-click “USB Input Device [Logitech Download Assistant]”. Select Driver tab, click Uninstall, check “Delete the driver software for this device”, and then click OK.

Once it is uninstalled, scan for hardware changes. This may take a while and will eventually reinstall the device. When it is finished, restart your computer. If this doesn’t fix the problem, uninstall Logitech Download Assistant using Add or Remove Programs.

Login/Register to Answer

Related Questions