TeamViewer error Dependency is not satisfiable: libc6-i386 (>=2.4)

Asked By 70 points N/A Posted on -

Hi experts,

Today I was trying to install TeamViewer on my laptop with Ubuntu OS but I got this dependency error. Also I tried to install them but no success. I contacted many Ubuntu forums and no one came up with a solution that work. Can anyone in here help me to fix this error? What is this dependency error?


Dependency is not satisfiable: libc6-i386 (>=2.4)

Answered By 575265 points N/A #186169

TeamViewer error Dependency is not satisfiable: libc6-i386 (>=2.4)


Actually, the error “Dependency is not satisfiable: libc6-i386” doesn’t only appear when installing TeamViewer. You can also get it when installing or updating Wine, installing Oracle, Picasa, as well as Steam. It seems that you are installing the latest version of TeamViewer and supposedly it will work on Ubuntu since it is supported.

There are actually different ways you can install the application on Ubuntu and the one you used is using the context menu which is done by right-clicking on the installer package and selecting “Open with software installation”, “Open with Ubuntu Software Center”, or “Open with GDebi package installer”. It may also show you “Open with” and then selecting “QApt package installer”.

These context menus vary depending on your distribution and the one you used is via Ubuntu Software Center which is also good. But the recommended method of installing it in Ubuntu is using the graphical installer. Try double-clicking on the downloaded TeamViewer installer package to start the graphical installation. If this is successful, just follow the instructions to complete the installation.

If it doesn’t work, run the following command in the terminal without quotes and then hit Enter: “sudo dpkg -i teamviewer_linux.deb”. In case you encounter a problem with the “dpkg” command indicating missing dependencies, complete the installation using the following command without quotes: “sudo apt-get install -f”. If you still get an error, download the “tar.gz” package from the download section.

It can be started without installing it. Once the package is downloaded, unpack it to a folder where you want to run TeamViewer. To start TeamViewer, just click on “teamviewer” to open it. In case you encounter an error on missing libraries, run the following command without quotes to identify the missing libraries: “tv-setup –checklibs”.

Login/Register to Answer

Related Questions