Specific RPC error message: Error 0x6d9

Asked By 10 points N/A Posted on -


I am facing a bit of a problem with Exchange 2010 test environment.

Currently I have a DB and it has a replica Status of "ServiceDown".

When I tried to mount the database I got this following error:

Microsoft Exchange Error

Failed to mount database 'DB01'.


The RPC query to retrieve the copy status for Database DB01 failed. The service might not be running. Error message: A server-side administrative operation has failed. The Microsoft Exchange Replication service may not be running on server exchange.company.local. Specific RPC error message: Error 0x6d9 (There are no more endpoints available from the endpoint mapper) from cli_GetCopyStatusEx2

I am new to swap, but I make sure that the service specified with the latest Exchange services and they all are set up.

I have tried some reboots just for fine measure as well. 

Please help me.

Thanks in advance.

Answered By 5 points N/A #98409

Specific RPC error message: Error 0x6d9


The steps below will fix the issue you are experiencing:

  • Make sure that the RPC Service is Started, Automatic in the Windows 2003 Server and then stop the RPC Locator Service manually.
  • Check the keys below in the Registry of Windows XP and Windows Server 2003. You will have to ensure that the ClientProtocols key does exist on HKLMSoftwareMicrosoftRpc registry subkey. Check also if the values below are contained in ClientProtocolsentry:
Name Type Data
ncacn_http REG_SZ rpcrt4.dll
ncacn_ip_tcp REG_SZ rpcrt4.dll
ncacn_nb_tcp REG_SZ rpcrt4.dll
ncacn_np REG_SZ rpcrt4.dll
ncacn_ip_udp REG_SZ rpcrt4.dll


  • Check is DNS is working properly. Click Start button, then Run, and type cmd and press Enter on the computer with the problem. Type Netdiag –v in the command line or try do ping –a IP on the server with the problem.
  • Port 135 which is used for TCP/UDP and ports 1024-65535 which are used for TCP should be open for RPC to work. It is very important that these ports should not be blocked by the firewall in hardware, firewall in internet connection, or the anti-virus. Run the Portgy tool on a PC that is not having the same problem against a computer with the existing RPC errors through the use of –n switch.

Login/Register to Answer

Related Questions