Solution For 0x800700424 Error

Asked By 0 points N/A Posted on -

Today, I was trying to allow a program to access through my windows firewall. It was saying that ‘To do so, I have to change some settings to default so, I did it. But after doing it, this 0x800700424 error message starts occurring. I’m unable to fix this error because I had never faced such a problem before. Please provide the steps to fix it.

Answered By 0 points N/A #325688

Solution For 0x800700424 Error


Before closing your firewall, you should always make sure that there is no virus or malware on your PC. The first thing you should do is to perform a hardware scan to detect the presence of malware in your system. Now, go to


If you find any file named ‘CONSRV.DLL’, then it means that your PC is infected with a zero-access rootkit. Download registry files from this link or from here.

You must launch them on your PC. Now, reboot your PC.

  • After restarting it, press Windows and R keys together and type ‘Regedit’ in the Run prompt.
  • Click on ‘SYSTEM.’
  • Select ‘CurrentControlSet.
  • Click on ‘Services.’
  • Select ‘BFE.’
  • Now, right-click on the ‘Permissions.’
  • Click on ‘ADD.’
  • Type ‘Everyone.’
  • Click on ‘OK.’

Now close these tabs.

  • In the search bar type- ‘Control Panel.’
  • Open it.
  • Click on ‘System and Security.’
  • Select ‘Window’s Firewall.’
  • Enable the firewall by turning it on.
  • Go to the ‘Customise Settings.’
  • Click on ‘Turn off Windows Firewall.’
  • Click on ‘OK.’
Answered By 590495 points N/A #326649

Solution For 0x800700424 Error


I think you are referring to error code “0x80070424” which is related to Windows Firewall. The full error reads, “Windows Firewall can’t change some of your settings”. You may get this error when you try to run Windows Update or manage Windows Firewall and can appear on Windows XP, Windows Vista, Windows 7, and Windows 8.x.

The problem here is with the “Windows Modules Installer” service or the “TrustedInstaller.exe” file. First solution is to try to restart the service. Press the Windows key + R to bring up the “Run” dialog then type without quotes “services.msc” then hit Enter. In the “Services” window, scroll down and look for the “Windows Modules Installer” service. Double-click it to open the “Properties”.

In the properties window, in “General” tab, “Startup type” should be set to “Manual”. Click “Start” to start the service manually then click “OK”. Run the Windows Firewall again then see if it works.

Related Questions