SmartQ V5 Android 2.1 Firmware

Asked By 0 points N/A Posted on -

I have recently installed ‘SmartQ V5 Android 2.1 MOD’ firmware on my SmartQ Android device.

After successfully installing the firmware, an error message popped-up (See attached screenshot). Unfortunately, I cannot download the firmware from the Android website. And also, I tried flashing my Android’s ROM three times, but still, the same result. Do you have any suggestions for this case?

I would appreciate your feedback on this, it will save me a lot of trouble.


The process has stopped unexpectedly. Please try again.

Answered By 10 points N/A #120263

SmartQ V5 Android 2.1 Firmware


Well if you are trying to download the application directly from the phone's browser I will suggest the you download the application from a computer and the use a USB cable or Bluetooth to transfer the application from the computer to the phone and install it manually. It seems like your phone does not have support for the download of such applications, or the application that you are downloading could be so large and therefore cannot fit directly on the phone location that it being directed to for saving.

If you have not yet configured the internet settings for the phone, especially after you flushed its contents then you need to contact the customer support of your mobile service provider and ask them to send you the settings. You may also need to call the customer support of the phone and inform them about your situation.

Thompson Locker


Related Questions