Problems installing CCC on windows

Asked By 0 points N/A Posted on -


Hi everyone,

I’ve tried installing CCC but I’m getting nowhere. I tried uninstalling the framework and disabling it on windows. They seem to have an effect on the problem and I get this MOM error message:

Could not load file or assembly ‘CLI.Implementation, Version=2.0.2589.34531, Culture=neutral, PublicKeyToken=90ba9c70f846762e’ or one of its dependencies. The system cannot find the file specified.


Anyone with any idea what I’m doing wrong?

Best Answer by Denise Dinkel
Answered By 0 points N/A #122790

Problems installing CCC on windows


What you need to do is to check the dependencies of the program you are installing or the so called CCC. The error says some of the program dependencies are missing or cannot be found.

Also check the compatibility of the program. Is this program was design for 32 bit operating system? Is this program is designed for 64 bit operating system? If it so, is it your operating system compatible with that program? Are you using a 32 bit or 64 bit operating system? This is the common problem of installation errors like this.

But for the best answer, you may find the website of the program or application you are installing and seek for a support from them. I am sure they are the one who can give you the exact explanation for this as well as the solution.

Best Answer
Best Answer
Answered By 0 points N/A #122791

Problems installing CCC on windows



Try following steps:

1)      Uninstall Catalyst Control Center

2)      Restart your computer

3)      Backup your Registry editor (copy “regedit” file from C:Windows to some backup location – for example, create new folder C: BACKUP)

4)      Open your Registry editor (click Start – Run, type regedit and press „Enter“, or click Start, type regedit in search field and click on regedit in search results)

5)      Ensure that these locations in registry editor are empty:



6)      Check location C: Program Files (or Program Files x86) ATI Technologies/ – delete subfolder ATI.ACE if it exists

7)      Go to C: Windows Assembly directory and check are there any items with Publy Key Token „90ba9c70f846762e“. If there are such, uninstall all of them by clicking right mouse button on them and selecting „uninstall“

8)      Ensure that you can see Hidden files in your system. Check location C: Documents and Settings (or Users) (name of user) AppData Local ATI ACE – it should be empty. If not , delete all in ACE folder.

9)      Restart your computer.

10)  Install fresh copy of CCC.

Login/Register to Answer

Related Questions