Printer Spooler Service is not running

Asked By 0 points N/A Posted on -


Hi ,

My printer is not showing up in Printers and other Hardware Devices Window. I have Windows XP installed on my PC, and when I try to add my EPSON LX-300 printer, it installs normally but does not show up in Printers and other Hardware Window. When I try to print from Microsoft Word, it says Printer Spooler service is not running. I tried to run it from Administrative Services but it doesn't work. In Services, the status is blank and the startup is automatic.

Can anybody provide a solution ?



Answered By 0 points N/A #82100

Printer Spooler Service is not running


To look for your printer you can go to the Control Panel and check for the Hardwares of the computer. You can also try to uninstall and reinstall your printer to see if the computer will recognize it. Also is your printer is connected to your PC through a USB Cable, it could be the problem as Windows XP have a history of not being able to detect external devices such as a USB. To remove the Printer Spooler status, have you tried changing the status in the Administrative services? For the Status, it should be Started. Sometimes the Start-up is set to Automatic but due to some errors you still have to start it manually.

Login/Register to Answer

Related Questions