Light on SteelSeries Sensei mouse is blinking

Asked By 10 points N/A Posted on -
qa-featured

I use a SteelSeries Sensei mouse for gaming, but just recently, it decided not to work anymore. The light which is located under the scroll wheel is blinking repeatedly. I know the latest version of SteelSeries Engine is being used. I tried it on a different computer and it worked. What should I do?

SHARE
Answered By 0 points N/A #199875

Light on SteelSeries Sensei mouse is blinking

qa-featured
HELLO
 
Please following steps for solving mouse problem.
 
1. Please check that you have latest steel series engine version. 
 
2. Please change the setting from control panel, In power option change to high performance when using USB devices.
 
3. In the option put the computer to sleep change it to never.
 
4. In the advanced setting please disable the USB suspending setting.
 
5. Please use the Steel Series firmware tool for upgrade firmware.
 
6. In the administrator right click on repair tool and run the fix for your particular product.
 
7. If all still not works then install product in different computer and try to run the latest firmware.
 
 
If all these not works then please contact to your service provider.
Answered By 575300 points N/A #310623

Light on SteelSeries Sensei mouse is blinking

qa-featured

If your mouse started functioning incorrectly after updating its driver, the mouse software is probably not compatible with your system. Before updating the driver, make sure the latest version supports your operating system. If your mouse is using the latest engine, SteelSeries Engine 3.12.3, try reverting to the previous version. Download the free version of Revo Uninstaller and install it.

Once installed, start Revo Uninstaller then select your mouse software among the applications and click “Uninstall”. Follow the normal uninstall process. When uninstall is complete, click “Scan” to scan your computer for any leftover files and delete everything it finds. This removes everything the program created on your computer. When it is finished, close Revo Uninstaller then install the previous version of the engine.

This should fix the problem. The latest SteelSeries Engine 3.12.3 supports Windows 7, Windows 8.x, and Windows 10. If you verify your computer is compatible, try downloading the SteelSeries Engine 3.12.3 again. Also, try downloading other software for your mouse then see if the problem gets fixed.

Login/Register to Answer

Related Questions