LibreOffice does not respond while saving a file

Asked By 50 points N/A Posted on -

I use LibreOffice in my Lenovo laptop and it worked perfectly until recently, it started to have issues saving a file. It locks up whenever I save a file regardless of its size. I tried deleting the old user profile and created a new one. I also removed the hardware acceleration, no go. No changes were made recently so I couldn't think of anything that could have caused this problem. Any help please? 

Answered By 0 points N/A #199880

LibreOffice does not respond while saving a file


This is a problem with the latest version of the LibreOffice suite. You are not the only one facing it.

The best solution for now is to wait for an update or download an older version of LibreOffice from this link and then select a version prior to what you have now and the operating system you use.

Another temporary solution is that whenever you save a documents or file from LibreOffice, when the save menu appears and start to hang, do not press anything and leave it as it is because it will unfreeze itself and then you can easily navigate and save the file how you want to.

This issue has been around since the beginning of June and a new LibreOffice suite is in the workings right now, so please be patient.

Login/Register to Answer

Related Questions