Launching Avid Media Composer fails with an Exception

Asked By 0 points N/A Posted on -

Hi friends,

Whenever I launch Avid Media Composer, I get this error message:’ Exception: SYS_ERROR, status: 87, msg: The parameter is incorrect.’ I was using Media Composer 3.5 without any issues. Ever since I upgraded to Media Composer 4, I face this problem. I tried uninstalling and reinstalling a couple of times and this did not work. I thought I’d go back to the earlier version and again uninstalled Media Composer 4 and tried installing the Media Composer 3.5. But now I find that this version of Media Composer throws this exception too. Help!!! What could have gone wrong? I have not installed ant new programs other than an update of McAfee antivirus. Please can you help me with this issue? Thank you for your valuable help.

Exception: ERROR_OTHER

Exception: SYS_ERROR, status:87, msg:The parameter is incorrect.

Answered By 590495 points N/A #179573

Launching Avid Media Composer fails with an Exception


If you are using Avid Media Composer 4 and it fails on your computer, you should check again the compatibility of your computer because it is possible that your operating system is not supported or you upgraded your operating system and then reinstalled the application which is not allowed. If you are previously using Avid Media Composer 3.5 and it works perfectly on your computer then you are probably using Microsoft Windows XP.

But even if this is the case, you should also be able to use Avid Media Composer 4 on your computer because it supports both Windows XP and Windows Vista. You can try running the program as administrator. Right-click on Avid Media Composer’s icon on the desktop and select Properties. Select Compatibility tab and check “Run this program as an administrator” under Privilege Level and then click OK.

After that, start the program again and see if it works. In case you are using an operating system older that Microsoft Windows XP such as Windows Millennium or Windows 2000, don’t expect the program to run because it is not supported. If the problem continues, try reinstalling Avid Media Composer 4 and make sure your operating system is supported.

Login/Register to Answer

Related Questions