Lab view error creating daqmx channel

Asked By 0 points N/A Posted on -


LabVIEW shows me this error code when I run a Data Acquisition Program. Every time the result is the same for me. I didn’t find a solution for this yet. Can anyone help me please to fix this program error ? Why I have it ?

Thank you !

Error – 200220 occurred at DAQmx Create Channel (AI-Voltage-Vasic).vi:3

Possible reason(s):

Measurements: Device identifier is invalid.

Device Specified: Dev6

Task Name: _unnamedTask

Answered By 0 points N/A #180484

Lab view error creating daqmx channel


You have mixed up the things. Anyway to fix the error do the following steps.

  • Check if you have selected Dev2  in labview.
  • Change your alias of your USB… in Max to Dev 2.
  • Or select Dev 1 in labview.
  • Check the path also that you are providing.
  • In this way you can got best result.

You can solve the problem in another way also.

  •  Open up the block diagram in your Labview.
  • Double click one of the "myDAQ" blocks.
  • MyDAQ wizard will be opened.
  • Go to "Channel settings" click the green arrow.
  • In "Current Physical Channels" find out "MyDAQ /aio"  type list.
  • What is seen in the left side of forward slash, is "device identifier"
  • Now here you can change "myDAQ" identifier that match your "MyDAQ"
  • Now your problem will be solved regarding identifier.

Login/Register to Answer

Related Questions