IPhone 4 error code 9912, please help!

Asked By 370 points N/A Posted on -

Hi everyone,

I have a new iPhone  4 and I keep on getting an error message.

"Error occurred attempting to download the file. (ICA error code –9912)"   

While trying to import picture files from the iPhone to Picasa application on the Mac.

I first thought that my camera roll was corrupted and was kind of confusing Picasa and iPhoto, which turned out not to be the case.

I spent quite a lot of time, looking for solutions from the web, tried them out, all of them failed to solve the problem. For instance there was a person experiencing the same issue and was offered the following solution;

– Open Image Capture
– Click on your iPhone under Devices
– Import as many of the photos that you can without an error.  (You will lose anything you don't get downloaded.)
– Once you've saved everything you can, select all the photos and videos on the phone.   Click the Delete button in the bottom toolbar (red circle.)  That should remove everything.  (Note:  I actually had to do it twice to get them all.)
– Quit Image Capture
– Unplug your iPhone
– Click on Photos on the phone
– Your albums should now show as empty.  Take a new photo and try importing to Picasa.

He commented back that, it had  worked for him. I have tried this several times and even gave it to other people to try it on my phone, nothing positive.

My question is that, is there any other way to fix the problem apart from the one I have listed?

Please help.


Best Answer by conover3
Answered By 0 points N/A #107699

IPhone 4 error code 9912, please help!


Dear ChesterWallace,
Your camera roll is working fine and the said problem relates to Picasa application. There are two possible solutions for your


Solution 1:
You should use should log in and do a file search.  You will find this down in a Prefs file. You will delete  /var/mobile/Media/iTunes_Control/iTunes/iPhotoAlbumPrefs. Then try to reconnect with image capture and I hope it will work.

Solution 2:
Download two blank squares, delete the images from the iPhone after download.  Then re-download the remaining in Picasa and it will work fine.

Take Care


Best Answer
Best Answer
Answered By 0 points N/A #107700

IPhone 4 error code 9912, please help!


The option to fix the problem you have described has worked for some people.

Option 1 (iPhone that is not jailbroken)

1. Try to refresh the iPhone by holding down the power butting and home button until the Apple logo appears on the screen. Once that happens, release the buttons.

2. Connect your iPhone to your computer using the USB cable provided when you purchased it.

3. Find and open the iSync program under the Applications folder. (If iSync is not on your computer, go to https://support.apple.com/kb/index?page=search&src=support_site.globalheader.search&locale=en_US&q=os%20x%20leopard and download it)

4. Click the top menu and choose Preferences.

5. Under the Advanced Section, click Reset Sync History. (At first glance, you may think nothing occurred, actually the history was reset)

6. Close iSync and now try to import the photos into iPhoto. (They should sync to iPhoto)

7. Next, open Finder and find the files for the pictures you opened in the iPhoto folder.

8. You then should be able to right-click and move to open with and select Picasa.

9. From there, it should begin to transfer the pictures to Picasa!

Option 2 (If IPhone is jailbroken)

1. A file could be keeping you from being able to move these pictures. It would be hidden under the iTunes_Control folder.
2. Delete the file named…   /var/mobile/Media/iTunes_Control/iTunes/iPhotoAlbumPrefs
3. Reconnect via Picasa and iOS should recreate that file which should fix it.
4. It should work if the first option did not.

Hope this helps,


Answered By 10 points N/A #107701

IPhone 4 error code 9912, please help!


Hello Chester,

The following is what you will need to do in order to resolve the issue that you are getting:

  • First, you will need to refresh the phone. To do that, you will need to hold down the power button and then the home button until the Apple appears on the screen, and after that release it.
  • Next you will need to try refreshing sync history as follows:
  • Locate iSync under Applications and then open it.
  • After that go to the top menu and then click on iSync and choose Preferences.
  • And then go under the Advanced Section and then click on Reset Sync History.
  • Once you have done that, you can go ahead and close iSync and then try importing your photos with iPhoto again.

Hope this helps.




Login/Register to Answer

Related Questions