I get Crystal Reports error when running B1UP. Can I fix this?

Asked By 20 points N/A Posted on -

I only had a real problem on each Crystal Report I run just after I upgraded from 8.81 PL08 and to 8.82 PL04 and At first it seemed fine before I had it upgraded. But unluckily, my B1 user name is now supplied as the value in the selection box just when I run the Crystal Report.

I started receiving an error message which I find hard to understand: ”SAP Business One Crystal Report Error executing script Item – Form item is not editable [Macro Command: Set($[$1000005.0.0]|$[UserName])]Macro Environment parameters:[Current Form: 410000100 – Quarterly 941 From Hist.” Can you please tell me what it means?

Do I have to hire an expert to fix this or can I do this on my own? I am quite irritated with this for I can’t push through with what I really want to do because of this. How can I manage to really get rid of this? 

Answered By 0 points N/A #146169

I get Crystal Reports error when running B1UP. Can I fix this?


If you have upgraded to a newer version and got problems, the best thing is to downgrade to the previous version but with a proper procedure so that the installations are not messed up.

  1. First make sure that you try the newest version from their website as it might include a fix for your problem. If it stills does not solve the problem the do the following.
  2. Delete the program or uninstall the newer version that you did.
  3. Download Ccleaner from filehippo.com and run the Registry cleaner from it. It will delete any registry entries in the computer relevant to the software or any other program.
  4. After that, install the version of the program that was working fine.

Login/Register to Answer

Related Questions