I cannot start logos 4.2a

Asked By 300 points N/A Posted on -

I am facing two problems. When I try starting Logos I receive the message:  “Logos4 Indexer has stopped working”.

There is a message that an update is ready to be installed when I try to run Logos. If I try to install it (by clicking yes),I get runtime error saying “This program has requested the Runtime to terminate in an unusual way.” The only log file in the Log Files folder is Logos4IndexerCrash.txt.

I am running Logos 4.2a SR-3 (

Any suggestion regarding these problems will be appreciated.

Answered By 588155 points N/A #104117

I cannot start logos 4.2a


If this is the first time this happens on your application, try restarting your computer then try it again. This should also fix it if this is a new installation. But if it still doesn’t work, try doing a clean installation of the program again to remove possible corrupted files in its installation. Uninstall the application then check your computer for any possible errors.

Use a disk utility application to check the system. For a much thorough diagnostics on the system, use a disk utility application like Norton Utilities, or Norton SystemWorks. Install the application again after this.

You may also need to check the compatibility of the application if the program still doesn’t work. It’s possible that your operating system is not supported by the program or there is another component that you overlooked and forgot to install. Visit the web site again where you downloaded this application and check for its system requirements there.

Login/Register to Answer

Related Questions