I cannot run nRoute software

Asked By 0 points N/A Posted on -

I get this error message ” There is a problem with nRoute registry. Re-install the nRoute please and run it again. ” when I run this program. This happened when I downloaded latest nRoute update and no problems occur during installation. Without any success, I tried to re-install the program.  What do I need to do to get nRoute to function, and does any one have such experience with this type of problem?

Best Answer by Edwon Redrikk
Answered By 0 points N/A #103899

I cannot run nRoute software


Dear Alfonso,

You said that you have downloaded it and installed it well. Are you sure there is no problem with the downloaded file. Was the extraction of that file happened successfully without any corruption of file? If there are no issue about none of it then please try to check these facts:

1. If you don't have MapSource installed then nroute is not going to work, so check its existence

2 Is there nay administrative issue involved when installation is in process, if it is, then try to install it as ADMINISTRATION.

3. If you have MapSource then try to reinstall it.

Best Answer
Best Answer
Answered By 5 points N/A #103901

I cannot run nRoute software


Whatsup Alfonso, the main solution to this problem is with the settings of the registry. There are certain settings that need to be changed in the registry. I have had a problem with such a software before and followed these steps;

Go to Start->Run->Registry editor

Once you open the registry, you need to go to H_KEY_LOCAL_MACHINESOFTWAREGaminMapSourceFamiliesNT


Once you open the folder and file, add this code;

"ID" hex=eb,08

"IDX"="C:\Garmin\City Navigator AmericaNT 2011.2CNNANT_2011_30.mdx"

"MDR"="C:\Garmin\City Navigator AmericaNT 2011.2CNNANT_2011_30_mdr.img"

"TRF"="C:\Garmin\City Navigator AmericaNT 2011.2

"TYP"="C:\Gamin\City Navigator AmericaNT 2011.2


"Loc"=C:\Gamin\City Navigator AmericaNT 2011.2\"

"Bmap"=C:\Gamin\City Navigator AmericaNT 2011.2\CNNANT_2011_30.img"

"Tdb"=C:\Gamin\City Navigator AmericaNT 2011.2\CNNANT_2011_20.tdb"

After typing the code, reinstall the latest definition of mapsource,nroute,city select and reboot your computer.

The software should work when you rerun the program,


Related Questions