Error 1075 on sharing internet connection

Asked By 980 points N/A Posted on -


I have just bought another computer and must be connected to the internet, so I need to share my other computer's internet connection.

When I was in the process of empowerment of the function, there was an error that services were not started.


Could not start the Windows Firewall/Internet Connection Sharing (ICS) service on Local Computer.

Error 1075: The dependency service does not exist or has been marked for deletion.

So what I did was, I've checked in services, Yes in fact, that it has not started. So I try to start it, did not start. So that rebooted me the computer in hope only reverts.

Restarted the computer, I went to internet sharing, the same error appeared. Is it because the services not yet started?

I'm posting this question in the hope that I can get some help.

Thank you.

Best Answer by Acosta
Best Answer
Best Answer
Answered By 0 points N/A #122995

Error 1075 on sharing internet connection



  1. I have the same problem as before, and treatment of this procedure to solve my problem. I hope that this will work for you.
  2. Click Start and then click Help and Support.
  3. In Select a task, click Tools to use to view your computer information and diagnose problems.
  4. In the tools area, click System Configuration utility.
  5. In the right pane, click System Configuration utility open. This opens the system configuration utility.
  6. Click the Services tab.

    • Make sure that all of the following services are turned on. To activate a service, click to select the check box.

      • Service application layer gateway
      • Network Connections
      • Knowledge of network location (NLA)
      • Plug and Play
      • Remote Access Auto Connection Manager
      • Remote Access Connection Manager
      • Remote Procedure Call (RPC) telephony
  7. Click OK and then click Restart.
  8. Once restarted Windows, re-run the wizard to share Internet connection.


Answered By 0 points N/A #122997

Error 1075 on sharing internet connection


Dear Judithmads,

You do not need to turn on your windows firewall system. Let it turn off. Internet network sharing is very easy to use.

Please do the following as I say:

  • Go to control panel from start menu or from my computer.
  • Click on the Network and Sharing Center.
  • Click on Local Area Connection and go to its properties.
  • Click on the sharing tab
  • Check the box which shows that ‘Allow other network user to connect through this computer's Internet connection’
  • Ok it and apply it for your settings and close the dialog box.
  • I think your problem is solved.

Thank you.


Login/Register to Answer

Related Questions