Database Upgrade Assistant Error in Oracle

Asked By 1290 points N/A Posted on -

Hi all,

System issue stated below occurs during the process of running DBUA from 11.2.0. $ORACLE_HOME is giving me an error when I tried to connect with sqlplus /nolog from both home 10.2.0 and 11.2.0, it is doing great without any nightmare issues.
Database Upgrade Assistant
There is an error in creating the following process:
/db/data/dbase/10.2.0/bin/sqlplus -S /NOLOG
The error is:
This is the first time I encountered this issue. I don't consider myself very proficient with oracle, that is why I am running out of ideas on this matter. The only thing I tried is set the ORACLE_SID and ORACLE_HOME parameters of 11.2.0 before launching the DBUA. I also checked on PATH variable. This is somewhat of a desperate situation,
Please help me pin point where shall I go next in illuminating this error.
Answered By 0 points N/A #122544

Database Upgrade Assistant Error in Oracle



Hi Mr. Paulartney,
As you have said earlier that this is the first time you are getting an error while running DBUA (Database Upgrade Assistant), you should not use ORACLE_SID and ORACLE_HOME parameters of 11.2.0, you must use ORACLE_BASE and ORACLE_HOME because oracle _base is the main root for oracle database directory tree and oracle _ home corresponds to the environment in which database products run. 
So you have to set ORACLE_BASE and ORACLE_HOME gives benefits (contains sub directories for Oracle database software executables and network files). Upgrading can be done easily without any issues and now you can run DBUA.
The following are the syntax for oracle_base and oracle _home:
oracle _base = /opt/oracle/product/11.2.0 (for release 2) { As u are dealing with 11.2.0}
oracle _home = /opt/oracle/product//"oracle release"/ db1.
Even after running these setting DBUA checks for:
1. Pre-upgrade checks like invalid user accounts, missing SQL scripts, checks for rollback segments and also.
2. Automated upgrade tasks like invoking upgrade scripts, modify requires table spaces.
So no errors occur while upgrading.

Login/Register to Answer

Related Questions