Forefront Endpoint Protection 2010 Reporting Services

Asked By 20 points N/A Posted on -


I have deployed Forefront Endpoint Protection 2010 on existing Server 2008 SP2 (64-bit) I have installed SQL Server 2005 (64-bit) Standard Edition with SP3 along with SCCM 2007 with R3 and SP3 which is under production. During the installation of SQL server I have faced lots of problems with the installation of pre-requisites and also I was not able to detect the version of Integration Services that was installed. I have also tried by installing SP4 for SQL Server 2005 but this didn’t resolve the problem. I have upgraded the SQL server to SQL Server 2008 R2 w/SP1, them the Integration Services version issue fixed

After installing all pre-requisites. It seemed to me that everything is going well until I was met with another failed installation of Reporting/Alerting services. I have installed this service manually and again it failed. I have checked in FepReport_*.log located at C:ProgramDataMicrosoft ForefrontSupportServer it says

MSI (s) (C8:48) [14:19:50:481]: Product: Microsoft Forefront Endpoint Protection 2010 Reporting — Installation operation failed.

MSI (s) (C8:48) [14:19:50:482]: Windows Installer installed the product. Product Name: Microsoft Forefront Endpoint Protection 2010 Reporting. Product Version: 2.1.1116.0. Product Language: 1033. Installation success or error status: 1603.

MSI (s) (C8:48) [14:19:50:484]: Deferring clean up of packages/files, if any exist

MSI (s) (C8:48) [14:19:50:484]: MainEngineThread is returning 1603

MSI (s) (C8:98) [14:19:50:485]: RESTART MANAGER: Session closed.

Error 1603 is very general, and this refers to TCP 1433 being blocked. Then I tried a manual install from fepreport.msi this gives me the below error.


Error 26201. Error -2147217900:failed to create SQL database: error detail: Incorrect syntax near ‘DATABASE

Answered By 5 points N/A #198498

Forefront Endpoint Protection 2010 Reporting Services



Hi Harvey

One of the possible reasons of this error in your SQL Database is when you are attempting to run a query / procedure or logic which is not compatible with your version of SQL Server. For example, You had a SQL Server 2000, and you upgraded it to a higher SQL Server version such as SQL Server 2005 or SQL Server 2008. The database object compatibility must be also upgraded to a higher version that suits the compatibility of your upgraded SQL Server.

When database compatibility and SQL Server version does not have its compatibility. You’ll encounter this kind of error.

So here is the fix for that error:

Modify the database compatibility level using these commands:

If you are using SQL Server 2005:
EXEC sp_dbcmptlevel 'DatabaseName', 90

IF you are using SQL Server 2008:
EXEC sp_dbcmptlevel 'DatabaseName', 100

I hope this helps.


Login/Register to Answer

Related Questions